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 Modul Praktikum Sistem Operasi 

 

 

PRAKTIKUM 1 DAN PRAKTIKUM 2 

Mengenal Command Prompt Dengan  D O S 

 

Setelah kuliah ini, Mahasiswa diharapkan akan dapat : 

a. Mengerti perintah-perintah dasar internal di DOS 

b. Mengerti pengaturan nama file (filename) di DOS. 

c. Menampilkan isi directory dan file ke monitor. 

d. Create, copy, rename, delete file dan directory. 

 

Topik yang akan dipelajari : 

✓ Nama file di DOS. 

✓ Beberapa perintah DOS yang sering digunakan (Internal Command) 

✓ Daftar Istilah 

 

Pada system operasi terbaru berbasis Windows saat pertama kali computer dihidupkan akan 

langsung masuk ke antarmuka system windows, namun jika DOS digunakan sebagai sistem 

operasi utama, maka setelah proses booting selesai akan masuk ke antar muka system DOS, dan 

system akan siap menerima perintah user. Akan tampak C: C:\>, yang disebut command prompt. 

Pada sistem operasi Windows untuk masuk ke command prompt DOS dapat dilakukan dengan 

cara, yaitu : 

• Klik tombol Start 

• Pilih All Program _ windows system _ command prompt 

• Atau dari tombol start _ pilih run _ ketik cmd 

Nama File di DOS 

Nama file terdiri atas 2 bagian, yaitu: 

• Nama file 

• Extension file 

Di dalam DOS, nama file hanya dapat ditampilkan 8 karakter awal dan 3 karakter setelah tanda 

titik (.) Sistem ini dikenali juga dengan istilah 8.3. Di dalam Windows mendukung nama file 

255.3 dan di Windows terbaru mendukung nama file hingga 255.255.255.255 ………. 

File-file disimpan dalam suatu directory yang berada di suatu memori  penyimpanan tertentu. 

Di DOS file dispesifikasikan pula oleh lokasi tempat file tersebut berada (PATH). PATH 

menunjukkan drive dan directory tempat file tersebut berada. 
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Beberapa Perintah DOS yang sering digunakan (Internal Command) 

Berikut ini akan dibahas mengenai beberapa perintah DOS yang sering digunakan. 

Legenda: 

[] : perintah yang di dalam kurung siku adalah optional (boleh dipakai, boleh tidak).  

<>  : tekan tanda di dalam <> 

1. Perintah date 

Digunakan untuk melihat atau mengubah tanggal hari ini di komputer kita. 

Cara penulisan : 

date [dd-mm-yy] 

 

Langkah-langkah penggunaan : 

1. Ketik date pada command prompt C:\> date <enter>. 

2. Jika tanggal akan diubah, ketik tanggal yang dikehendaki pada tempatnya (misal: 

akan jika diubah menjadi 25/04/2022, maka ketik 25-04-22), kemudian tekan enter. 

Jika tanggal tidak akan diubah, langsung tekan enter. 

2. Perintah time 

Digunakan untuk melihat atau mengubah tanggal hari ini di komputer kita. 

Cara penulisan : 

time [hh:mm[:ss[,xx]]] 

 

Langkah-langkah penggunaan : 

1. Ketik time pada command prompt (C:\> time). 

2. Jika waktu akan diubah, ketik waktu yang dikehendaki pada tempatnya (misal: akan 

jika diubah menjadi pukul 8.00, maka ketik 8:00), kemudian tekan enter. Jika waktu 

tidak akan diubah, langsung tekan enter. 

3. Perintah ver 

Digunakan untuk melihat versi DOS yang digunakan. 

Cara penulisan : 

ver 

Langkah-langkah penggunaan : 

1. Ketik ver pada command prompt (C:\> ver). 

2. Tekan enter. 

4. Perintah cls 



 

Page | 4  

 

 Modul Praktikum Sistem Operasi 

Digunakan untuk membersihkan layar 

Cara penulisan : 

cls 

 

Langkah-langkah penggunaan : 

1. Ketik cls pada command prompt (C:\> cls). 

2. Tekan enter. 

 

5. Perintah dir 

Digunakan untuk menampilkan isi suatu directory ke layar. 

Cara penulisan : 

dir [drive:][path] [file apa saja yang akan di-listing] [/p][/w][/a] 

[drive:] : Menampilkan daftar (listing) isi file yang ada di drive tersebut. 

[path] : Menampilkan daftar (listing) isi file yang ada di path tersebut. 

[file apa saja yang akan dilisting] : 

Penentuan file apa saja yang di-listing dapat menggunakan karakter wildcard (? & *). ? : 

1 karakter apa saja * : semua karakter 

Contoh : 

?oba.txt : Semua file yang diawali dengan huruf apa saja, asalkan diikuti oba.txt  

coba.* : Semua file bernama coba dengan extension apa saja. 

[/p][/w] : Penampilan file yang dilisting pada layar. 

[/p] : ditampilkan per page (per layar), 

[/w] : ditampilkan secara menyamping, langsung seluruh file. 

[/a] : Seluruh file, termasuk file dengan atribut hidden, ditampilkan. 

 

Langkah-langkah penggunaan : 

1. Ketik perintah dir yang akan digunakan pada command prompt. 

2. Tekan enter. 

3. Listing file yang ada di directory akan terlihat di layar. 

Latihan : 

Melisting semua file yang bukan hidden yang berada di C. 

C:\> dir <enter> 

C:\> dir/p <enter> 

C:\> dir/w <enter> 
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C:\> dir *.* <enter> 

C:\> dir /p/w <enter> 

Melisting semua file (termasuk yang hidden) yang panjang namanya adalah 3 dan berada 

di C. 

C:\> dir ???.* /p/w/a <enter> 

6. Perintah md / mkdir 

Digunakan untuk membuat directory. 

Cara penulisan : 

md [path] nama_directory 

mkdir [path] nama_directory 

Langkah-langkah penggunaan : 

1. Ketik perintah md atau mkdir yang akan digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan 1 : 

md data <enter> 

mkdir program <enter> 

md latihan <enter> 

mkdir data\databaru <enter> 

md data\datalama <enter> 

md program\program1 <enter> 

md program\program2 <enter> 

md program\program3 <enter> 

 

7. Perintah cd / chdir 

Digunakan untuk berpindah dari 1 directory ke directory lain. 

Cara penulisan : 

cd [[path] nama_directory] 

chdir [[path] nama_directory] 

Nama_directory dapat diganti dengan : 

. : nama_directory yang sedang aktif (user berada) sekarang. 

.. : nama_directory di mana directory yang sedang aktif berada. 

 

Langkah-langkah penggunaan : 



 

Page | 6  

 

 Modul Praktikum Sistem Operasi 

1. Ketik perintah cd atau chdir yang akan digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan : 

cd data <enter> 

cd databaru <enter> 

cd ..\..\other <enter> 

cd .. <enter> 

cd program <enter> 

cd ..\ <enter> 

 

8. Perintah rd / rmdir 

Digunakan untuk menghapus directory. 

Cara penulisan : 

rd [path] nama_directory 

rmdir [path] nama_directory 

 

Langkah-langkah penggunaan : 

1. Ketik perintah rd atau rmdir yang akan digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan 1: 

rd program\program1 <enter> 

rmdir program\program3 <enter> 

Terdapat dua kelemahan perintah RD: 

1. Tidak dapat membuang direktori sekiranya masih ada sub direktori di dalam direktori 

yang ingin dibuang. 

2. Tidak dapat membuang direktori sekiranya masih file di dalam direktori yang ingin 

dibuang. 

3. Tidak dapat membuang direktori kalau kita sedang berada dalam direktori yang akan 

dibuang tersebut. 

Ingat : MD = Make Directory, RD = Remove Directory, CD = Change Directory. 

 

Latihan 2: 
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1. Pada C:\> ketik perintah MD UJIAN dan CD UJIAN. Prompt akan menjadi C:\UJIAN> 

2. Pada C:\UJIAN> ketik perintah MD COBA dan CD COBA. Prompt akan menjadi 

C:\UJIAN\coba> 

3. Pada C:\UJIAN\COBA> ketik perintah CD.. (dua titik). Prompt akan berganti menjadi 

C:\UJIAN> 

4. Pada C:\UJIAN> ketik perintah CD.. dan prompt akan bertukar menjadi C:\> 

5. Pada C:\> ketik perintah CD \UJIAN\COBA. Prompt akan bertukar menjadi 

C:\UJIAN\COBA>. 

6. Pada C:\UJIAN\COBA ketik perintah CD \ ,prompt akan bertukar menjadi C:\> 

7. Pada C:\> ketik perintah RD UJIAN. Berhasil? 

8. Pada C:\> ketik perintah CD UJIAN dan kemudian RD COBA. Berhasil? 

9. Pada C:\UJIAN> ketik perintah CD .. dan kemudian RD UJIAN. Berhasil? 

 

9. Perintah copy con 

Digunakan untuk membuat file. 

Cara penulisan : 

copy con [drive:][path]nama_file 

Langkah-langkah penggunaan : 

1. Ketik copy con nama_file pada command prompt. 

2. Tekan enter. 

3. Akan tampil cursor, tempat user dapat mengetikkan isi file. 

4. Ketikkan isi file sampai selesai. 

5. Setelah selesai, tekan Ctrl+Z. Akan tampil “1 file(s) copied” pada layar. Hal ini 

berarti file telah terbentuk. 

 

Latihan : 

copy con data\datalama\coba1.txt <enter> 

Hallo <enter> 

Ini file percobaan doang <Ctrl+Z><enter> 

copy con data\datalama\coba2.txt <enter> 

Hallo lagi<enter> 

Ini file laen lagimestinya <enter> 

<Ctrl+Z><enter> 
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10. Perintah redirection (>, <, >>, <<) 

Digunakan untuk mengeluarkan hasil ke suatu file. 

Cara penulisan : 

perintah_DOS operator_redirection [drive:][path]nama_file 

Operator redirection : 

• A > B : hasil A dimasukkan ke B. 

• A < B : A menerima input dari B. 

• A >> B : hasil A ditambahkan ke B. 

• A << B : A menerima tambahan input dari B. 

 

Langkah-langkah penggunaan : 

1. Ketik perintah pada command prompt. 

2. Tekan enter. 

 

Latihan : 

dir/w > data\datalama\isi_w.txt <enter> 

dir data\datalama\c*.txt > data\datalama\isi_c.txt <enter> 

dir data\*.* > data\datalama\isi_a.txt <enter> 

dir program\*.* >> data\datalama\isi_a.txt <enter> 

 

11. Perintah type 

Digunakan untuk menampilkan isi file ke layar. 

Cara penulisan : 

type [drive:][path]nama_file 

 

Langkah-langkah penggunaan : 

1. Ketik perintah type yang ingin digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan : 

type data\datalama\isi_a.txt <enter> 

type data\datalama\coba2.txt <enter> 
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12. Perintah copy 

Digunakan untuk meng-copy isi file yang satu ke file yang lain. 

Cara penulisan : 

copy [drive:][path]nama_file_asal [drive:][path]nama_file_tujuan 

 

Langkah-langkah penggunaan : 

1. Ketik perintah copy yang ingin digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan 1: 

copy data\datalama\isi_a.txt data\datalama\isi_all.txt <enter> 

copy data\datalama\isi_a.txt data\databaru\isi_a.txt <enter> 

copy data\datalama\ data\isi_lama <enter> 

Perintah COPY adalah untuk membuat salinan ke lokasi lain seperti floppy disk atau direktori 

lain pada harddisk. Sama juga seperti perintah DELETE, perintah COPY juga dapat 

menggunakan ? dan *. 

1. COPY *.* C:\latihan - semua file akan disalin ke direktori C:\latihan 

2. COPY *.DOC C:\latihan – semua file berakhir dengan *.DOC akan disalin ke direktori 

C:\latihan 

3. Perintah COPY /Y digunakan sekiranya ingin membuat salinan dengan tidak 

mempedulikan file tersebut telah ada atau tidak. gambar berikut, membuat perintah COPY 

buat kali kedua (autoexec.old), perintah copy akan berhenti sampai kita menjawab YES, 

NO atau ALL untuk mengganti file tersebut. Tetapi apabila kita tambah /Y pada perintah 

COPY, instruksi akan terus dilaksanakan. Pilihan /Y ini sangat berguna sewaktu kita ingin 

mengganti file yang rusak 

 

Latihan 2: 

1. Pada C:\> jalankan perintah COPY COMMAND.COM COMMAND.ORG dan 

jalankan perintah DIR untuk melihat file yang baru dibuat. 

2. Pergi ke D:\> jalankan perintah COPY *.COM C:\ dan jalankan perintah DIR untuk 

melihat file yang baru dibuat. 

3. Pada D:\> jalankan perintah COPY *.COM C:\ sekali lagi dan jalankan perintah DIR 

untuk melihat file yang baru dibuat. 
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4. Pada D:\> jalankan perintah COPY /Y *.COM C:\ lagi sekali dan jalankan perintah DIR 

untuk melihat file yang baru dibuat. Perhatikan perbedaan antara no. 2, 3 dan 4. 

 

13. Perintah ren / rename 

Digunakan untuk mengubah nama file/directory. 

Cara penulisan : 

ren [drive:][path]nama_file/directory_lama 

[drive:][path]nama_file/directory_baru 

rename [drive:][path]nama_file/directory_lama 

[drive:][path]nama_file/directory_baru 

 

Langkah-langkah penggunaan : 

1. Ketik perintah rename yang ingin digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan : 

ren data\datalama\isi_a.txt data\datalama\isi1.txt <enter> 

ren data\datalama\coba2.txt data\datalama\cobalg.txt <enter> 

ren data\dataold\ data\datatua <enter> 

 

14. Perintah del / delete 

Digunakan untuk menghapus file. Jika nama file yang dihapus merupakan nama directory, maka 

semua file yang ada dalam directory tersebut akan dihapus. 

Cara penulisan :  

del [drive:][path]nama_file 

Langkah-langkah penggunaan : 

1. Ketik perintah delete yang ingin digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan : 

del data\datalama\isi1 <enter> 

del data\datalama\ <enter> 
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15. Perintah prompt 

Digunakan untuk mengubah command prompt DOS. 

Cara penulisan : 

prompt [prompt-text] 

Prompt-text dapat berupa teks apa saja yang diinginkan oleh user atau dapat juga berupa 

perintah-perintah berikut, semua perintah di bawah diawali dengan menuliskan tanda $ : 

• t : waktu di DOS 

• d : tanggal di DOS 

• p : PATH 

• v : versi DOS 

• n : indeks dari drive yang aktif 

• g : > 

• l : < 

• b : | 

• q : = 

• h : backspace, menghapus satu karakter sebelumnya. 

• e : karakter escape. 

• -  : 1 baris kosong. 

 

Langkah-langkah penggunaan : 

1. Ketik perintah prompt yang ingin digunakan pada command prompt. 

2. Tekan enter. 

 

Latihan : 

prompt apa? <enter> 

prompt anda di $p <enter> 

prompt $p$g <enter> 

 

TUGAS : 

1. Tampilkan tanggal sekarang pada komputer, tulis hasilnya 

2. Gantilah tanggal sekarang menjadi tanggal 03-08-2020, tuliskan langkah dan hasilnya 

3. Tampilkan waktu sekarang pada komputer, tulis hasilnya 

4. Gantilah waktu sekarang menjadi tanggal 14.00, tuliskan langkah dan hasilnya 
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5. Tuliskan versi DOS yang anda gunakan dengan menggunakan perintah yang telah 

dipelajari diatas 

6. Buatlah sebuah direktori dengan nama ”UBG”, kemudian masuklah ke direktori 

tersebut, tuliskan hasilnya 

7. Buatlah sebuah file dengan nama coba.txt, isikan datanya “saya mahasiswa UBG”, 

tuliskan hasilnya 

8. Dari hasil pembuatan file tersebut, tampilkan isi file kemudian tuliskan hasilnya 

9. Gantilah prompt C: anda dengan nama UBG:, tuliskan hasilnya 

10. Kembalikan prompt UBG: menjadi propmt C:, tuliskan hasilnya 
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PRAKTIKUM 3 DAN PRAKTIKUM 4 

MICROSOFT WINDOWS  

Setelah kuliah ini, Mahasiswa diharapkan akan dapat : 

1. Mengenal tampilan desktop windows. 

2. Mengenal elemen-elemen yang tedapat di windows (seperti icon, shortcut). 

3. Mengerti utility internal untuk manajemen harddisk dan system di Windows. 

4. Mengenal istilah-istilah yang sering digunakan di Windows. 

 

Topik yang akan dipelajari : 

✓ Desktop Windows, icon, shortcut, penggunaan dan fungsinya. 

✓ Hirarki Windows, manajemen file dan direktori. 

✓ Utility internal Windows 

✓ Istilah-istilah di windows dan penjelasannya, (cut, copy, paste, drug ‘n drop, plug 

‘n play, double click, right click, dll), hingga  

✓ Setting Printer 

 

MENGUBAH SETTING PERFORMA LAYAR 

Pilihlah bagian Settings dari Display Properties 

1. Color Pallete _ Untuk mengatur berapa banyak warna yang di kenali oleh komputer 

(bergantung pada Video Card ). 

2. Desktop Area _ Untuk mengatur resolusi layar. 

3. Resolusi berkaitan erat dengan kualitas gambar yang dihasilkan layar. Semakin 

besar resolusi yang dipilih, semakin bagus kualitas gambar yang di hasilkan. 

TUGAS 1 

1. Rubahlah resolusi pada layar menjadi 1280 x 1024 atau 800 x 600, bagaimana hasilnya? 

 

MEMPERBAIKI KERUSAKAN PADA DISK ANDA 

Kerusakan yang terjadi pada sebuah disk akan sangat mempengaruhi performa dari disk 

tersebut. Akan tetapi, sungguh beruntung sekali bahwa kerusakan yang terjadi pada disk 

sebagian besar ialah kerusakan tidak serius yang dapat dengan mudah diperbaiki oleh 

program perbaikan disk. Dengan menggunakan Microsoft Windows, kita pun dapat 

memperbaiki sebagian dari kerusakan-kerusakan tersebut. 

Langkah-langkahnya ialah sebagai berikut : 

2. Klik kanan pada Menu START dan klik File Explorer 

3. Klik kanan pada drive tujuan anda dan pilihlah Properties. 

4. Kliklah tab Tools 

5. Klik “Check” pada bagian Error Checking. 
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6. Sebelum kita menjalankan program ini terdapat 2 pilihan yang dapat kita modifikasi.  

7. Automaticaly fix file system errors : Dengan men-cek pilihan ini, Windows akan 

secara otomatis memperbaiki setiap kerusakan yang ditemuinya. 

8. Scan for and attempt recovery for bad sectors : Dengan men-cek pilihan ini, selain 

memeriksa file dan direktori pada drive yang kita pilih akan adanya kerusakan, 

Windows pun memeriksa drive tersebut akan adanya kerusakan fisik. 

 

TUGAS 2 

1. Lakukan perbaikan pada disk C:, kemudian pilih Automaticaly fix file system errors, 

jalankan perintah tersebut, catat waktu yang dibutuhkan ( perkiraan berapa menit ) dan 

tuliskan hasil keterangan setelah selesai 

2. Lakukan perbaikan pada disk D (bila ada), kemudian pilih Automaticaly fix file system 

errors, jalankan perintah tersebut, catat waktu yang dibutuhkan ( perkiraan berapa menit ) 

dan tuliskan hasil keterangan setelah selesai 

3. Lakukan perbaikan pada disk C:, kemudian pilih Scan for and attempt recovery for bad 

sectors, jalankan perintah tersebut, catat waktu yang dibutuhkan (perkiraan berapa menit) 

dan tuliskan hasil keterangan setelah selesai 

4. Lakukan perbaikan pada disk D (bila ada), kemudian pilih Scan for and attempt recovery 

for bad sectors, jalankan perintah tersebut, catat waktu yang dibutuhkan ( perkiraan berapa 

menit ) dan tuliskan hasil keterangan setelah selesai. 

 

MENDEFRAG HARDISK ANDA 

Langkah - langkah untuk mengoperasikan program Defragmentasi pada Windows ialah 

sebagai berikut : 

1. Pilihlah bagian Tools dari Drive Properties anda. Pada Optimize and Defragment Drive 

Pilih Klik OPTIMIZE. 

2. Pilihlah drive hardisk yang ingin anda defrag. 

3. Klik lah “Defragment”. 

4. Apabila kita lihat gambar diatas, terdapat tombol “Analyze” dan tombol “Optimize”. 

5. Tombol “Analyze” digunakan untuk melihat keadaan data pada hardisk anda tanpa 

mendefragnya. 

6. Dan tombol “Optimize” digunakan untuk melihat keadaan data pada hardisk anda, lalu 

mendefragnya. 
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TUGAS 3 

1. Lakukan defrag pada hardisk anda, sebelum proses defrag dimulai lakukan analize 

terlebih dahulu, kemudian setelah selesai tampilkan hasilnya dengan mimilih report. 

Tuliskan hasilnya : berapa total fragmentation, file fragmentation dan free space 

fragmantation, kemudian lakukan defrag. 

2. Apa yang dapat anda pelajari dari hasil praktik diatas 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Page | 16  

 

 Modul Praktikum Sistem Operasi 

PRAKTIKUM 5 DAN PRAKTIKUM 6 

MICROSOFT WINDOWS 

 

MEMPEBESAR RUANG KOSONG PADA HARDISK ANDA 

Langkah-langkahnya ialah sebagai berikut : 

1. Bukalah Drive Properties anda pada bagian General. 

2. Kliklah tombol “Disk Cleanup”. Apabila itu telah dilakukan akan muncul dialog box 

seperti berikut: 

 

 

TUGAS 1 

1. Lakukan disk cleanup pada hardisk C :, kemudian catat apa saja yang dibersihkan dan catat 

juga berapa menit/detik perkiraan waktu yang dibutuhkan. 

 

MEMATIKAN PROGRAM YANG MEMBEKU 

Berikut adalah langkah-langkahnya : 

1. Kliklah Ctrl+Alt+Del 

2. Pada kolom Status semua program dalam keadaan Running, yang berarti bekerja 

dengan baik. Akan tetapi, apabila terdapat program yang Hang, status program tersebut 

akan tertulis Not Responding. 

3. Untuk mematikan program tersebut, pilihlah program tersebut lalu klik tombol “End 

Task”. 



 

Page | 17  

 

 Modul Praktikum Sistem Operasi 

4. Pada bagian bawah dialog box menunjukkan processes : … ( menunjukkan berapa 

program yang diproses ) dan disamping terdapat CPU usage … (menunjukkan berapa 

persen CPU yang digunakan ) 

5. Ada kalanya, sebuah program yang membeku menyebabkan seluruh komputer anda 

membeku sehingga ketika anda menekan Ctrl+Alt+Del, dialog box diatas tidak 

muncul. Pada saat ini, satu-satunya cara untuk mengatasi hal ini ialah dengan cara 

mere-start komputer anda. 

 

TUGAS 2 

1. Lakukan langkah diatas, catatlah program apa saja yang sedang dijalankan komputer, dan 

catat juga program yang membeku (jika ada) dan matikan program yang membeku 

tersebut 

2. Catatlah berapa banyak proses yang dikerjakan komputer saat itu, dan berapa rata-rata 

CPU yang digunakan dalam satu menit. 

 

MENGHAPUS PROGRAM DARI WINDOWS 

Menghapus program adalah bagian yang sangat penting dalam Windows karena hal ini 

sangatlah sering kita gunakan. Di Windows ada cara tersendiri dalam menghapus suatu 

program, yaitu: 

1. Start Menu _ Control Panel _ Add/Remove Program 

2. Pilihlah program yang ingin anda hapus. 

3. Lalu klik Change/Remove. 

Sebenarnya dengan menggunakan fasilitas ini, anda pun dapat menginstall sebuah program ke 

komputer anda. Akan tetapi, sekarang ini karena pada umumnya program penginstallan telah 

tersedia di CD program, penginstallan akan lebih mudah dengan menggunakan program 

tersebut. 

 

TUGAS 3 

1. Lakukan langkah diatas, kemudian catatlah program apa saja yang dapat diremove (ada 

dalam box add or remove program). 
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MELIHAT HARDISK 

Untuk melihat hardisk yang terpasang didalam komputer langkahnya adalah : 

1. Klik kanan start, klik explorer 

2. Klik my computer 

3. Untuk melihat kapasitas hardisk yang terpasang, klik kanan pada bagian hardisk 

kemudian klik propertis 

Used space : menunjukkan ruang hardisk yang telah digunakan 

Free space : menunjukkan ruang hardisk yang masih kosong 

Capacity : menunjukkan besar kapasitas hardisk. 

 

TUGAS 4 

1. Berapa hardisk yang terpasang pada komputer anda, dari masing-masing hardisk catatlah 

ruang hardisk yang masih kosong, yang telah digunakan dan besar kapasitasnya. 

 

SYSTEM PROPERTIS 

Untuk mengetahui komponen yang terpasang didalam komputer dapat dilakukan dengan jalan 

sebagai berikut : 

1. Klik start, klik run 

2. Ketikkan dxdiag, tekan enter 

3. Maka akan muncul directx diagnostik, terdapat beberapa tab yang mempunyai fungsi 

berbeda-beda 

System : untuk mengetahui tanggal, SO, prosesor Ram dll yang terpasang pada 

komputer 

Display : menampilkan card VGA yang digunakan 

Sound : menampilkan sound card yang digunakan 

Input : menampilkan alat input yang terpasang. 

 

TUGAS 5 

1. Catatlah informasi tentang SO yang digunakan, Prosesor, kapasitas RAM, nama 

komputer, type BIOS dan versi direct 

2. Catatlah driver VGA, sound card dan alat input yang terpasang pada komputer anda. 
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PROGRAM STARTUP 

Program startup merupakan program yang akan aktif setiap pertama kali system windows 

dijalankan, program ini dapat diaktifkan dan juga dapat dinonaktifkan. Untuk mengaktifkan 

atau sebaliknya melalui langkah-langkah sebagai berikut : 

1. Klik start_run 

2. Ketikkan msconfig, tekan enter 

3. Maka akan tampil system configuration 

4. Klik pada tap startup 

5. Pada startup item, bagian yang ada centangnya berarti program yang aktif setiap kali 

windows dijalankan 

6. Untuk mengaktifkan atau sebaliknya hilangkan/berikan centang dengan cara meng-klik 

pada kotak kecil disamping nama program 

 

TUGAS 6 

1. Catatlah program apa saja yang pertama kali aktif setiap pertama kali windows 

dijalankan 

2. Apa yang dapat anda pelajari dari hasil praktik diatas 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Page | 20  

 

 Modul Praktikum Sistem Operasi 

PRAKTIKUM 7 

CONTROL PANEL 

 

Didalam menu control panel terdapat beberapa icon yang sangat membantu kita untuk 

melakukan konfigurasi terhadap system operasi (windows), sebagai icon telah dipelajari 

pada praktik sebelumnya. Untuk menjalankan icon-icon tersebut cukup anda double klik 

pada menu yang diinginkan 

1. Date and time : digunakan untuk mengatur waktu dan tanggal yang terdapat didalam 

komputer 

2. Display : digunakan untuk mengatur themes, desktop, screen saver, apperenace dan 

setting 

3. Font : menampilkan model font yang terpasang pada komputer, untuk menambahkan 

font ke dalam komputer, dari menu font anda klik file_install new font…., pada menu 

add font bagian folder anda arahkan dimana font baru yang akan dimasukkan berada, 

kemudian klik select all, klik OK 

4. Keyboard : untuk konfigurasi keyboard yang digunakan. 

5. Tab speed digunakan untuk mengatur kecepatan keyboard 

6. Tab hadware untuk mengetahui model/jenis keyboard yang terpasang 

7. Mouse: untuk konfigurasi mouse yang digunakan. 

8. Button: mengatur klik kanan/klik kiri dan kecepatan double klik 

9. Pointer: mengatur jenis-jenis pointer mouse 

10. Pointer option: mengatur efek pointer 

11. Wheel: mengatur scrolling 

12. Hadware: mengetahui jenis/type hadware ( mouse ) yang digunakan 

13. Network connection : untuk konfigurasi jaringan, baik yang LAN atau dial-up 

14. Printer and faxes : untuk konfigurasi printer dan fax yang akan digunakan dalam 

komputer. Untuk menambahkan daftar printer klik add pada printer task. Kemudian 

ikuti langkah-langkah untuk instalasi. 

15. User accounts : untuk konfigurasi user ( penggantian nama user, gambar user, 

pemberian pasword, membuat dan menghapus user baru dll ) 
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Mengganti nama user : 

1. Klik pada user yang ingin diganti namanya 

2. Klik rename, klik OK 

Mengganti gambar user : 

1. Klik pada user yang ingin diganti gambarnya 

2. Klik change my picture, pilih gambar klik change picture 

Memberi password : 

1. Klik pada user yang ingin diberi password 

2. Klik Create a password, ketikkan password pada type a new password 

3. Ketikkan sekali lagi password pada type a new password again to confirm 

4. Klik create password 

5. Restar komputer untuk melihat hasilnya 

Membuat user baru : 

1. Klik a new account 

2. Isikan nama user yang akan dipakai 

3. Klik next, klik create account 

4. Restar komputer untuk melihat hasilnya 

 

TUGAS 1 

1. Dari icon date time, catatlah tanggal dan waktu sesuai dalam komputer anda. 

Kemudian rubahlah tanggal komputer menjadi 03-08-2022, lihat hasilnya dan beri 

keterangan 

2. Dengan menggunakan icon display, rubahlah themes dengan cara klik themes 

kemudian pilihlah salah satu pilahan themes pada theme kemudian klik apply apa 

yang terjadi catatlah perubahan tersebut 

3. Dengan menggunakan icon display, rubahlah desktop dengan cara klik desktop 

kemudian pilihlah wind pada background kemudian klik apply apa yang terjadi 

catatlah perubahan tersebut. 

4. Dengan menggunakan icon display, rubahlah setting monitor dengan cara klik setting 

kemudian pilihlah 800 x 600 atau 1024 x 768 dengan cara menggeser scroll pada 

screen resolution kemudian klik apply apa yang terjadi catatlah perubahan tersebut 

5. Catatlah informasi (model/jenis) hadware keyboard dan mouse yang digunakan pada 

komputer anda 



 

Page | 22  

 

 Modul Praktikum Sistem Operasi 

6. Didalam komputer anda ada berapa printer / faxs yang telah terpasang / terinstal, catat 

jumlah dan namanya 

7. Gantilah nama user account menjadi UBG, kemudian berikan password dengan 

password ubg1, restart komputer dan berilah keterangan anda 

8. Buatlah user baru dengan nama UBG new, kemudian restart komputer anda dan 

berikan keterangan 

9. Apa yang dapat anda pelajari dalam praktik diatas. 
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PRAKTIKUM 8 

PENGELOLAAN FOLDER DAN FILE 

 

WINDOWS EXPLORER 

Fasilitas didalam Sistem operasi Microsoft Windows untuk mengatur /membuat Folder dan 

File adalah Windows Explorer. Windows Explorer menampilkan scara lengkap isi dan 

hirarki suatu File dan folder serta menampilkan keseluruhan isi dari file tersebut. Untuk 

membuka aplikasi tersebut klik tombol Start Menu, lalu arahkan pointer ke Program dan 

pilih Windows System dan pilih  File Explorer.   Cara lain adalah dengan klik kanan mouse 

pada menu STAR dan pilih File Exploler. 

 

MENGUBAH TAMPILAN ISI FOLDER 

Dalam keadaan tetap, windows hanya memperlihatkan keterangan singkat tentang isi dari 

file explorer. Bila ingin mengubah tampilan isi folder tersebut yaitu dengan mengklik menu 

View atau tombol toolbar, 

Setelah melihat isi dari menu view, klik salah satu perintah tersebut. 

 

MENGUBAH URUTAN TAMPILAN FOLDER 

Apabila folder dan drive tidak beraturan secara abjad, maka langkah yang dilakukan agar 

terlihat rapi adalah mengklik menu View lalu arahkan pointer ke Arrange Icons by. 

Adapun pilihan tersebut adalah Name, Size, Type, Modified 

 

MEMBUAT, MENGHAPUS DAN MENGGANTI NAMA FOLDER 

Folder berfungsi diumpamakan rak yang dilengkapi dengan lacinya. Kegunaan lainnya 

adalah untuk tidak membingungkan pada saat penyimpanan data yang tergolong banyak 

jenis filenya. 

 

Panduan : Untuk memilih file atau folder lebih dari satu, dapat dilakukan dengan cara 

memilih salah satu file atau folder yang dipilih, lalu pindahkan pointer mouse pada file atau 

folder yang lain, tekan tombol Shift kemudian klik mouse pada file atau folder yang akan 

dikopi. Cara yang lain adalah dengan menggunakan tombol Ctrl, lalu pilih file atau folder 

sambil menahan tombol Ctrl. 

 



 

Page | 24  

 

 Modul Praktikum Sistem Operasi 

MEMBUAT FOLDER 

Untuk membuat folder, langkah-langkah yang harus dilakukan adalah sebagai berikut. 

1. Pada FIle Explorer, klik File arahkan pointer ke New > Folder atau dengan mengklik 

ruang kosong di sisi kanan File Explorer. 

Pada sisi kanan dari windows Explorer, folder akan muncul dengan nama New Folder. Nama 

folder tersebut dapat diketik dengan menekan tombol back space. Setelah mengetikkan nama 

folder tersebut, tekan Enter. 

 

MENGGANTI NAMA FOLDER 

Pilih folder yang akan diganti lalu klik menu File lalu arahkan pointer ke Rename lalu klik. 

Maka folder tersebut, meminta untuk mengganti nama folder tersebut. 

Tips: 

Folder dapat diganti namanya dengan cara pilih folder lalu tekan tombol F2. 

 

MENGHAPUS FOLDER 

Pilih folder yang akan dihapus, lalu klik menu File lalu arahkan pointer ke Delete lalu klik. 

Kotak dialog konfirmasi untuk menghapus, tetapi folder yang dihapus sebenarnya akan 

dipindahkan dulu ke Recycle Bin. Lalu klik Yes. 

 

MENGKOPI FOLDER 

Sebagai latihan buat dua folder, lalu berikan nama. Kopi folder berguna untuk 

menggandakan folder, file ke tempat yang lain. Pilih salah satu folder yang hendak dikopi, 

klik kanan folder yang dipilih, maka sub menu akan tampil lalu pilih Copy atau dengan 

combinasi tombol keyboard Ctrl + C. Lalu pilih Paste atau Ctrl + V. 

 

MEMINDAHKAN FOLDER DAN FILE 

Folder atau file dapat dipindahkan ke lokasi yang diinginkan, untuk memindahkan folder 

tersebut gunakan langkah sebagai berikut : 

1. Pilihlah folder atau file yang ingin dipindahkan 

2. Klik Edit lalu klik Cut atau dengan kombinasi tombol Ctrl + X. 

3. Pilih drive, folder atau tempat dimana file atau folder tersebut akan dipindahkan. 

4. Setelah memilih tempat tujuan, klik Edit kemudian pilih Paste atau kombinasi tombol 

Ctrl + V.  Langkah memindahkan file atau folder ini dapat dilakukan dengan mengklik 
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kanan file atau folder yang akan dipindahkan. Setelah itu pilih Cut, lalu pilih tempat tujuan 

dan klik Paste. 

MENGUBAH ATRIBUT FOLDER DAN FILE 

Folder dapat diubah atributnya sesuai dengan keinginan. Adapun atribut pada folder adalah 

sebagai berikut : 

1. Read Only, berfungsi untuk menutup akses penulisan ulang, atau hanya sekedar dibaca 

atau dilihat. 

2. Hidden, berfungsi untuk menyembunyikan folder. 

Perhatikan langkah-langkah berikut didalam mengubah attribut file dan folder. 

Mengaktifkan Read Only pada Folder 

1. Pilih Folder yang akan diubah attributnya dengan mengklik kanan folder tersebut. 

2. Kemudian arahkan penunjuk dan klik Properties. 

3. Check pada kotak check Read Only kemudian klik OK 

Mengaktifkan Hidden pada Folder 

1. Pilih Folder yang akan diubah attributnya dengan mengklik kanan folder tersebut. 

2. Kemudian arahkan penunjuk dan klik Properties. 

3. Check pada kotak check Hidden kemudian klik OK. 

 

TUGAS 1 

1. Rubahlah tampilan folder (tumbalis, Icons, list, detail) catatlah masing-masing perbedaan 

dari masing – masing tampilan tersebut 

2. Rubahlah urutan folder berdasarkan Name, Size, Type, Modified, catatlah perbedaan dari 

masing-masing perintah 

3. Buatlah folder baru dengan nama UBG, kemudian rubah nama folder tersebut menjadi 

UBG new, kemudian hapuslah folder tersebut. Tuliskan langkah kerja dari awal 

pembuatan sampai penghpusan 

4. Buatlah folder baru dengan nama hidden, aktifkan hidden terhadap folder tersebut 

kemudian klik view refres, tuliskan langkah kerja dan bagaimana hasilnya setelah di 

refresh. 

5. Tampilkan folder tersebut dengan cara : klik tool _ folder option, klik view klik show 

hidden files and folder klik OK, nonaktifkan hidden terhadap file tersebut kemudian klik 

view refers, tuliskan bagaimana hasilnya setelah di refresh ? 

6. Apa yang dapat anda pelajari dari praktik diatas 
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PRAKTIKUM 9 DAN PRAKTIKUM 10 

REGISTRY 

 

Registry termasuk bagian yang penting didalam sistem operasi windows, didalamnya 

terdapat beberapa instruksi yang dapat mempengaruhi sistem windows. Registri tersebut 

dapat diubah dan juga ditambah ataupun dihapus. Sebelum bermain-main dengan registri 

untuk menjaga keamanan backuplah terlebih dahulu registry anda. Untuk mengetahui hasil 

perubahan yang dilakukan dalam registri stiap selesai melakukan perubahan komputer harus 

direstart 

MELAKUKAN BACKUP REGISTRY 

1. Klik tombol Start > Run. 

2. Ketik regedit dan tekan Enter setelah berada didalam jendela Run. 

3. Didalam Registry Editor, pilih menu File > Export. 

4. Setelah Export Registry File muncul, masukkan nama file ke bagian File Name, 

misalnya backup-registry dan sebagainya. 

5. tekan tombol Save. 

 

MEMPERCEPAT SHUTDOWN 

HKEY CURRENT USER\CONTROL PANEL\DESKTOP 

Double click waittokillapptimeout ubah nilainya jadi 1000 Double click hunguptimeout 

ubah nilainya jadi 1000 

HKEY_USERS\.DEFAULT\CONTROL PANEL\DESKTOP 

Double click waittokillapptimeout ubah nilainya jadi 1000 Double click hunguptimeout 

ubahnilainya jadi 1000 

HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL 

Double click waittokillservicetimeout ubah nilainya jadi 1000 

 

MENGGANTI WALLPAPER 

HKEY_CURRENT_USER/Control Panel/Desktop 

Klik ganda pada wallpaper dan masukkan path gambar yang diinginkan pada Value 

Data. 
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MENGGANTI NAMA RECYCLE BIN 

HKEY_CLASSES_ROOT/CLSID/{645FF040-5081-101B-9F08-00AA002F954E} 

Klik ganda pada option (Default value) dan beri nama baru sesuai yang diinginkan pada 

Value Data. 

 

MEMUNCULKAN RENAME PADA RECYCLE BIN 

HKEY_CLASSES_ROOT/CLSID/{645FF040-5081-101B-9F08-

00AA002F954E}/ShellFolder 

Klik ganda pada Attributes > Edit Binary Value. Pada Value Data, ganti angka tersebut 

menjadi 0000 50 01 00 20. 

 

MENYEMBUNYIKAN RECYCLE BIN 

HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Expl

orer/Desktop/NameSpace 

Hapus subkey {645FF040-5081-101B-9F08-00AA002F954E}, kemudian Restart 

computer untuk melihat hasilnya. 

Untuk memunculkannya kembali, buat kembali kombinasi angka {645FF040-5081-

101B-9F08-00AA002F954E}. 

 

MENAMBAH ISI SHORTCUT MENU PADA RECYCLE BIN 

HKEY_CLASSES_ROOT/CLSID/{645FF040-5081-101B-9F08-

00AA002F954E}/ShellFolder 

Klik ganda Attributes dan ganti angka di Value Data dengan angka berikut ini: 

0000 50 01 00 20 > Rename 

0000 60 01 00 20 > Delete 

0000 70 01 00 20 > Rename & Delete 

0000 41 01 00 20 > Copy 

0000 42 01 00 20 > Cut 

0000 43 01 00 20 > Copy & Cut 

0000 44 01 00 20 > Paste 

0000 45 01 00 20 > Copy & Paste 

0000 46 01 00 20 > Cut & Paste 

0000 47 01 00 20 > Cut, Copy & Paste 
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MENAMBAH ISI SHORTCUT MENU PADA RECYCLE BIN DENGAN MENU 

PILIHAN 

HKEY_CLASSES_ROOT/CLSID/{645FF040-5081-101B-9F08-

00AA002F954E}/Shell 

Klik menu Edit > New > Key dan beri nama yang diinginkan (Misalnya: Go To 

Windows Explorer). 

Dibawah key yang baru tersebut, tekan lagi menu Edit > New > Key dan buat sebuah 

key baru bernama Command. 

Klik ganda option (Default), dan pada bagian Value Data, isi dengan path Windows 

Explorer (C:\WINDOWS\Explorer.exe). 

 

Mengembalikan Folder Documents Yang Hilang Di My Computer 

HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Explorer

/Doc FolderPaths 

Pilih menu Edit > New > String Value dan beri nama sesuai dengan username yang 

digunakan di Windows (contohnya: Chippers) 

Klik ganda pada value tersebut dan masukkan path tempat dimana Documents anda berada 

(contohnya D:\Documents) 

 

Menyingkirkan File Stored Dari My Computer 

HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Expl

orer/MyCo 

mputer/NameSpace/DelegateFolders 

Hapus subkey {59031a47-3f72-44a7-89c5-5595fe6b30ee} dengan menekan tombol Del. 

 

Menyembunyikan My Recent Documents 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Klik menu Edit > New > DWORD Value dan beri nama NoRecentDocsMenu. 

Kemudian klik ganda pada DWORD Value tersebut, dan berikan angka 1 untuk 

mengaktifkannya. 

 

Menyembunyikan Menu Find 
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HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Klik menu Edit > New > DWORD Value dan beri nama NoFind. 

Kemudian klik ganda pada DWORD Value tersebut dan berikan angka 1 untuk 

mengaktifkannya. Restart komputer. 

 

Menyembunyikan Help And Support 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Buatlah sebuah DWORD Value baru - Menu Edit > New > DWORD Value, dan beri nama 

NoSMHelp. 

Kemudian klik ganda pada NoSMHelp dan isi dengan angka 1 pada Value Data. Restart 

komputer. 

 

Menyembunyikan Menu Run 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Buat sebuah DWORD Value baru dan beri nama NoRun. Klik ganda dan masukkan angka 

1 sebagai Value Data. 

 

Menyembunyikan Menu Run Dari Start Menu (2) 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/A

dvanced 

Cari value bernama Start_ShowRun, klik ganda dan masukkan angka 0 pada bagian Value 

Data. 

 

Menyembunyikan Log Off 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Klik menu Edit > New > Binary Value dan beri nama NoLogOff. 

Klik ganda pada NoLogOff dan masukkan angka 01 00 00 00 pada bagian Value Data. 

 

Menyembunyikan Menu Turn Off Computer 



 

Page | 30  

 

 Modul Praktikum Sistem Operasi 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Klik menu Edit > New > DWORD Value dan beri nama NoClose. 

Klik ganda NoClose dan beri angka 1 pada Value Data. 

 

Clear type Pada Logon Screen 

HKEY_USERS/.DEFAULT/Control Panel/Desktop 

Klik ganda FontSmoothingType dan masukkan angka 2 pada Value Data. 

 

Membuat Tampilan Berbeda Pada Jendela Logon 

HKEY_USERS/.DEFAULT/Software/Microsoft/Windows/CurrentVersion/ThemeMa

nager 

Klik ganda ColorName dan masukkan teks Metallic pada Value Data. 

 

Menampilkan Administrator Di Welcome Screen 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 

NT\CurrentVersion\Winlogon\SpecialAccounts\UserLis t 

Buat sebuah DWORD Value baru dan beri nama Administrator. 

Klik ganda Administrator dan masukkan angka 1 pada Value Data. 

 

Menyembunyikan Ikon Printer & Faxes dari Start Menu 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/A

dvanced 

Cari value bernama Start_ShowPrinters dan berikan angka 0 pada Value Data. 

 

Menyembunyikan Control Panel Dari Start Menu 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/A

dvanced 

Cari value bernama Start_ShowControlPanel dan klik ganda pada bagian tersebut. 

Masukkan angka 0 pada Value Data. 

 

Menyembunyikan Menu My Pictures Dari Start Menu 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/A

dvanced 
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Klik ganda pada Start_ShowMyPics dan masukkan angka 0 pada bagian Value Data. 

 

Memunculkan Menu Administrative Tools 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/A

dvanced 

Klik ganda pada StartMenuAdminTools dan berikan angka 1 pada Value Data. 

 

Memperkecil Ikon Start Menu 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Explorer/A

dvanced 

Klik ganda pada Start_LargeMFUIcons dan masukkan angka 1 pada Value Data. 

 

Menghilangkan Username Pada Start Menu 

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre 

ntVersion\Policies\Explorer 

Pilih Edit > New > DWORD Value dan beri nama NoUserNameInStartMenu. 

Klik ganda NoUserNameInStartMenu dan masukkan angka 1 pada Value Data. 

 

Mencegah Perubahan Menu Start 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Buat sebuah DWORD Value baru dan beri nama NoChangeStartMenu. 

Klik ganda NoChangeStartMenu dan masukkan angka 1 pada Value Data. 

 

Mengganti Nama Ikon Internet Explorer 

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre 

ntVersion\Explorer\CLSID\{871C5380-42A0-1069-A2EA-08002B30309D} 

Klik ganda pada value (Default) disamping kanan, masukkan teks yang diinginkan pada 

Value Data. 

 

Menyembunyikan Device Manager 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies 

Pilih menu Edit > New > Key dan beri nama System. 

Di subkey System buatlah sebuah DWORD Value baru dan beri nama NoDevMgrPage. 
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Klik ganda NoDevMgrPage dan masukkan angka 1 pada Value Data. 

 

Menghapus StartUp Items Di MSCONFIG 

Klik Start > Run > ketik msconfig, kemudian klik pada tab startup, hilangkan tanda centang 

pada program yang ingin dihapus dari daftar startup. 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run 

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\Curre ntVersion\Run 

Hapus subkey yang berisikan program-program yang tidak diinginkan dengan menekan 

tombol Del. 

 

Mempercepat Proses Shutdown Windows XP 

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control 

Klik ganda WaitToKillServiceTimeout dan ubah nilainya menjadi lebih rendah dari 2000. 

Mengganti AM Dan PM Menjadi Pagi Dan Sore 

HKEY_CURRENT_USER/Control Panel/International 

Klik ganda s1159 dan ubah teks AM dengan PAGI. 

klik ganda s2359 dan ubah teks PM dengan SORE. 

 

Menonaktifkan Fungsi AutoRun 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Policies/Ex

plorer 

Klik ganda NoDriveTypeAutoRun dan masukkan angka 95 pada Value Data. 

 

Mematikan Secara Otomatis Program Not Responding 

HKEY_USERS/.DEFAULT/Control Panel/Desktop 

Klik ganda AutoEndTasks dan masukkan angka 1 pada Value Data. 

 

Memunculkan Option My Computer Yang Tersembunyi 

HKEY_CURRENT_USER/Software/Microsoft/Windows/CurrentVersion/Internet 

Settings/Zones/0 

Klik ganda Flags kemudian ganti menjadi Decimal dan masukkan angka 1 pada Value Data. 
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TUGAS 1 

1. Backup lah registri anda dengan nama regUBG, kemudian simpan pada direktori C:, berikan 

penjelasan 

2. Catatlah waktu shutdown pada komputer, kemudian hidupkan kembali dan lakukan setting 

untuk mempercepat shutdown dari registri. Catatlah waktu shutdown setelah dilakukan 

setting dan berapa selisihnya 

3. Gantilah nama recycle bin dengan nama “tempat sampah”, berikan penjelasan 

4. Munculkan rename pada recycle, kemudian berikan keterangan dari hasil praktik anda 

5. Sembunyikan menu ricent documents, run, log off, control panel dan turn off, berikan 

keterangan hasil praktik anda 

6. Cegahlah start menu agar tidak dapat dirubah oleh orang lain, berikan keterangan hasil 

praktik anda 

7. Apa yang dapat anda pahami dari praktik diatas 
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PRAKTIKUM 11 DAN PRAKTIKUM 12 

TIPS DAN TRIK WINDOWS 

 

MENCEGAH PENGGANTIAN SETTING DISPLAY PROPERTIES 

Anda dapat melakukan Setting display dari Control Panel - Display atau melalui klik kanan 

pada desktop, lalu pilih Properties. Dengan setting di bawah ini orang lain tidak dapat 

mengganti setting pada Display tersebut. 

Ikutilah langkah berikut: 

Klik Start——–>Run, ketikkan regedit lalu tekan Enter. 

Key:HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policie

s\System 

Value Name: NoDispCPL 

Data Type: REG_DWORD 

Data: (0 = disabled, 1 = enabled/mencegah penggantian) Shortcut untuk Shutdown 

Untuk mempercepat shutdown Anda bisa membuat shortcut pada desktop. Caranya : 

1. Klik kanan area kosong pada desktop lalu pilih New - Shortcut. 

2. Pada command line ketikkan c:\windows\rundll32.exe user, exitwindows. 

3. Klik next dan beri nama shortcut tersebut. 

4. Terakhir klik Finish. 

 

SHORTCUT UNTUK LOG OFF 

Untuk mempercepat log off Anda bisa membuat shortcut pada desktop. Caranya: 

1. Klik kanan area kosong pada desktop lalu pilih New - Shortcut. 

2. Pada command line ketikkan C:\WINDOWS\RUNDLL.EXE 

shell32.dll,SHExitWindowsEx 0 

3. Klik next dan beri nama shortcut tersebut. 

4. Terakhir klik Finish 

 

MENCEGAH PERINTAH SHUT DOWN 

Setting berikut akan mencegah seseorang untuk mematikan komputer Anda. Hal ini berguna 

jika misalnya Anda meninggalkan komputer untuk beberapa saat dan Anda khawatir ada 

orang lain yang akan men-Shut Down komputer Anda. 

Ikutilah langkah berikut : 

Klik Start_Run, ketikkan regedit lalu tekan Enter. 
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Key: HKEY_CURRENT_USER\Software\Microsoft\Windows 

\CurrentVersion\Policies\Explorer 

Value Name: NoClose 

Data Type : REG_DWORD 

Data: (0 = shutdown enabled, 1 = shutdown disabled) 

 

MENGCOPY DARI DOS PROMPT 

Suatu saat kamu mungkin ingin melakukan copy tampilan text yang ada pada Dos Prompt. 

Untuk itu ikuti tips berikut : 

Klik icon Mark yang terletak pada toolbar Dos Prompt. 

Pilih area yang ingin Anda copy dengan melakukan drag. 

Tekan icon Copy. 

Setelah itu Anda dapat melakukan Paste, misalnya pada Notepad, MS Word, dll. 

 

MENGUBAH ICON DRIVE DENGAN AUTORUN 

Pernah lihat icon Drive CDROM yang berubah ketika kita memasukan sebuah CD? nah.. hal 

yang sama bisa juga kita praktekkan pada Drive Harddisk. Bukalah Notepad anda dan ketik 

: 

[autorun] 

icon=nama icon.ico 

Save dengan nama autorun.inf dan letakan di root drive yang dituju ( ct : C:\ atau D:\ ) 

Selanjutnya, letakan file icon yang kita inginkan di tempat yang sama dengan file autorun.inf, 

lalu restart komputer anda. 

Tips : agar tampilan file di drive tidak berantakan, ubah atribut kedua file tersebut menjadi 

hidden. 

Kerusakan pada File win.com 

Saat booting windows Anda menampilkan pesan: 

The following file is missing or corrupted: Win.com 

The following file is missing or corrupted: Win.com 

Program too big to fit in memory Cannot find Win.com, unable to continue loading Windows 

Program too large 

Untuk mengatasinya, Anda harus membuat file win.com baru dengan cara mengekstrak file 

win.cnf dari CD Windows. Langkah komplitnya sebagai berikut : 

Ekstrak file win.cnf dari CD Windows ke folder C:\Windows. 
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Setelah diekstrak kemudian gantilah nama win.cnf menjadi win.com. Caranya : ren 

c:\windows\win.cnf c:\windows\win.com 

 

Shortcut ke Pengaturan System 

Biasanya anda harus mengklik kanan desktop lalus Properties. Sebenarnya ada cara yang 

lebih cepat yaitu dengan menggunakan shortcut. Caranya : 

1. Klik kanan pada desktop, pilih New - Shortcut. 

2. Pada command line, ketikkan C:\WINDOWS\CONTROL.EXE Sysdm.cpl, System,1 

3. Klik next dan beri nama shortcut tersebut. 

4. Terakhir klik Finish. 

 

DISABLE KLIK KANAN PADA DEKSTOP & WINDOWS EXPLORER 

Jika Anda meng-enable setting di bawah ini maka tidak ada yang bisa melakukan klik kanan 

pada Desktop & Windows Explorer. Dengan kata lain menu yang muncul waktu klik kanan 

tidak ada lagi. 

Ikutilah langkah berikut. 

Klik Start—->Run, ketikkan regedit lalu tekan Enter. 

Key: HKEY_CURRENT_USER\Software\Microsoft\Windows 

\CurrentVersion\Policies\Explorer 

Value Name: NoViewContextMenu 

Data Type: REG_DWORD 

Data: (0 = disabled, 1 = enabled) 

 

DISABLE KLIK KANAN PADA TASKBAR 

Jika Anda meng-enable setting di bawah ini maka tidak akan muncul menu waktu melakukan 

klik kanan pada Start Menu, Tab control, dan Clock.Ikutilah langkah berikut. 

Klik Start*Run, ketikkan regedit lalu tekan Enter. 

Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows 

\CurrentVersion\Policies\Explorer] 

Value Name: NoTrayContextMenu 

Data Type: REG_DWORD 

Data: (0 = disabled, 1 = enabled) 
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PERATAAN TEKS PADA DROP DOWN MENU 

Drop down menu = menu yg muncul saat Anda mengklik menu File, Edit, Help, dll pd 

berbagai aplikasi Windows 

Secara default, alignment pada drop down menu adalah rata kiri. Kalau Anda suka, Anda 

bias menggantinya menjadi rata kanan. Ikutilah langkah berikut. 

Klik Start—->Run, ketikkan regedit lalu tekan Enter. 

Caranya : 

Key: HKEY_CURRENT_USER\Control Panel\Desktop 

Value Name: MenuDropAlignment 

Data Type: REG_SZ 

Data: (0 = rata kiri, 1 = rata kanan) 

 

MEMPERCEPAT TAMPILAN START MENU 

Klik Start—->Run, ketikkan regedit lalu tekan Enter. 

Caranya : 

Key: HKEY_CURRENT_USER\Control Panel\Desktop 

Rubah Data MenuShowDelay yang semula 400 menjadi 0 

 

TUGAS 1 

1. Kunci / cegahlah agar display propertis pada komputer tidak dapat diganti, berikan 

keterangan 

2. Buatlah Shortcut shutdown, pengaturan system dan log off pada dekstop, kemudian 

lakukan uji coba terhadap shorcut tersebut, tuliskan keterangan anda 

3. Lakukan setting agar komputer anda tidak dapat di matikan/shut down, berikan 

keterangan anda 

4. Kopikan keterangan yang ada didalam DOS, tuliskan hasil kopian anda dari DOS 

tersebut 

5. Lakukan setting untuk mempercepat tampilan start menu program, catatlah perkiraan 

selisih waktu sebelum dan sesudah dilakukan setting 

6. Apa yang adan dapat pelajari dari praktik diatas 

 

 

 

 



 

Page | 38  

 

 Modul Praktikum Sistem Operasi 

PRAKTIKUM 13 

MENGAMATI PROSES CPU 

 

Untuk mengamati proses CPU yang digunakan, bukalah program Task Manager dengan cara 

tekan Ctr+Alt+Del pada keyboard secara bersamaan. Pada bagian bawah program terdapat 

keterangan berapa % CPU yang digunakan. 

 

 

TUGAS 1 

1. Amatilah dan catatlah rata-rata berapa % CPU yang digunakan dalam 1 menit ketika tidak 

ada aplikasi yang di buka 

2. Amatilah dan catatlah rata-rata berapa % CPU yang digunakan dalam 1 menit ketika anda 

memainkan lagu dengan aplikasi WinAmp 

3. Amatilah dan catatlah rata-rata berapa % CPU yang digunakan dalam 1 menit ketika anda 

membuka Ms. Word dan melakukan pengetikan 

4. Amatilah dan catatlah rata-rata berapa % CPU yang digunakan dalam 1 menit ketika anda 

membuka Ms. Excell dan melakukan pengetikan 

5. Amatilah dan catatlah rata-rata berapa % CPU yang digunakan dalam 1 menit ketika anda 

membuka Power Point dan melakukan pengetikan 

6. Amatilah dan catatlah rata-rata berapa % CPU yang digunakan dalam 1 menit ketika anda 

memainkan lagu dengan aplikasi Windows Media Player 
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7. Amatilah dan catatlah rata-rata berapa % CPU yang digunakan dalam 1 menit ketika anda 

membuka 10 program 

8. Dari pengamatan anda diatas berikan kesimpulan 

9. Apa yang dapat anda pelajari dari praktik diatas 

 


